ODBiC Discussion Board


RE: Reply on your questions, Ian, 12-28-2005

by Dave, December 29, 2005 08:26

Ok. Was it the wwwidigt.htm you mean? Basically, you have to change some paths to folders if you have not already done so AND the path to the products database.

From template1.odb:

<!--DATABASE DRIVER={Microsoft Access Driver (*.mdb)};DBQ=c:/httpfile/example/products.mdb;FIL=MS Access; UID=Admin -->

<!-- To configure for your setup, change these directory references: "/scripts/" to your CGI directory "/example/" to your ODBiC HTML template directory "/httpfile/" to your server's HTML root directory -->

You need to change the database path to wherever you put the products.mdb (DBQ=" ") and the paths to the files need to be changed as well. Please look up IIS on the forum for more details on setting up folder permissions.

Also, you might want to try something simple using the prodcuts.mdb table. Create a simple test.odb file with:

<!--NOTE: MAKE SURE TO CHANGE THE PATH TO THE DBQ TO WHEREVER YOU PUT THE PRODUCTS MDB DATABASE-->

<!--DATABASE DRIVER={Microsoft Access Driver (*.mdb)};DBQ=c:/httpfile/example/products.mdb;FIL=MS Access; UID=Admin -->$sql_error$

<!--SQL SELECT Category, ProductID, Heading, Description, UnitPrice, UnitsOnHand FROM Products ORDER BY ProductID-->$sql_error$

<!--TABLE-->

Now call the webpage http://your.ip.address/test.odb

You'll know pretty quickly what the problem is with the $sql_error$ command. If a bunch of records are returned, then you connected successfully. Now you can go back a re-setup the example files.

Hope this helps.

Dave


Replies:


Post Your Reply:

Name   
E-mail  optional
Topic  
Message:

HTTP Link: 
Link text: 

          


Copyright ©1997-2003, Roger Harris. All rights reserved.