ODBiC Discussion Board


RE: The problem may be restriction of the operation right for the odb.exe under IIS, Ian, 01-09-2006

You'd get a different error for access privileges or configuration error

by Roger Harris, January 10, 2006 14:46

404 just means "not found" so the either IIS doesn't really know about that cgi-bin directory, or odb.exe is not really on it.

In the IIS manager (which you can open from Administrative Tools), when you open the "(local computer)" root, then the Web Sites, then the Default Web Site, you should see a list of directories that IIS is using. Is cgi-bin in that list? If so, click on it, and you should see odb.exe listed. If cgi-bin is listed but odb.exe isn't listed, then you didn't put the file in the right place.

If cgi-bin is not listed, then you can create a Virtual Directory by right-clicking on the Default Web Site. Name it cgi-bin, then Browse to find the folder where you put odb.exe. Set the options to allow executables .

If that doesn't do it, I'm afraid I really can't tell you why you're getting that error, but as I said, 404 can only mean that the URL is not looking at the right directory, or the file isn't on that directory.


Replies:


Post Your Reply:

Name   
E-mail  optional
Topic  
Message:

HTTP Link: 
Link text: 

          


Copyright ©1997-2003, Roger Harris. All rights reserved.